Requirements for MW4.8

Nov 22, 2011 at 5:19 PM

Im looking at the site trying to track down the MW4.8 requirements. In other words what Windows versions are supported and what versions of Visual Studio are supported. Where can I find that? I looked but couldn't track it down.

 

AGP

Coordinator
Nov 23, 2011 at 11:01 AM

I don't know we're the page went that stated this but MapWindow v4.8 is for WinXP and up.
Uses .NET v3.5 (having only .NETv4 will not work) and the C++ 2008 redistributables (this is checked during installation).

The source code is maintained for Vis. Studio 2008.
Other solution files exists (VS2003 and VS2010) but they are not maintained and are likely to be out-dated.

For v4.9 we're discussing (http://mapwindow4.codeplex.com/discussions) to move to .NETv4 and Vis. Studio 2010.
Most likely we will.

I hope this helps.

Paul

Nov 29, 2011 at 11:04 PM

Good to know. As a programmer that wants to use the map control (and not compile the control itself) can I also expect to be able to use it in VS2010? I'm going to test here within the next week or so.

 

AGP

Coordinator
Nov 30, 2011 at 7:28 PM

I see no restrictions in using it with VS2010. You probably need to compile your application for .NETv3.5, though.

Let us know your test results.

Nov 30, 2011 at 8:56 PM
Edited Nov 30, 2011 at 9:31 PM

VS2010 and only having .NET 4.0 on computer will work when coding with MapWindow.

That is my current developing environment.

Stephen