Hillshade Raster?

Sep 10, 2012 at 12:16 PM
Edited Sep 10, 2012 at 12:31 PM

Hello everyone,

I got a problem and I don't find the solution. I have a grid and a specific GridColorScheme corresponding to the landuse. After visualisation, I got the good colors (also in the legend) but I have a shade on it.... I tried to open it with Mapwindows and i have the same result with the chekbox "Compute Hillshade". So, I tried to do something like : image.AllowHillshade=False, but nothing, I got the same result with shade. Do you have some information to not have the mode "compute hillshade" on?

I work with VB2010 and MapWinGis 4.8

This is my code to show the raster data :

 

Dim Show_Landuse As New MapWinGIS.Image
Dim Landuse As New MapWinGIS.Grid
Dim COLOR_Landuse_Grid As New MapWinGIS.GridColorScheme
Dim ConvertImage As New MapWinGIS.Utils


'I ERASE THE PART FOR THE GRID COLOR SCHEME...

Show_Landuse = ConvertImage.GridToImage(Landuse, COLOR_Landuse_Grid)
Legend_LANDUSE = Main.MapMain.AddLayer(Show_Landuse, True)

 '************* To have a good quality image at any resolution *************
Show_Landuse.UpsamplingMode = tkInterpolationMode.imNone
 '************** For the shade... But doesnt't work ************
Show_Landuse.AllowHillshade = False
Main.MapMain.Redraw()

 

Thanks!

Sep 11, 2012 at 4:52 PM

What I do when this happens is I load up the layer in a MapWindow project and then save the project. Open the MWPRJ file in notepad++ or some other advanced text editor. In the MapWindow app make your changes and save the project. You should be able to see what changes in the project file which is nothing more than XML. When I click on "Compute Hillshade" what I see changing is the ColoringType parameter but that is based on each break. So maybe experiment with that and see how that pans out.

Sep 12, 2012 at 11:07 AM

sindizzy, you're great! It's a very good idea to look in this .mwprj file! You find the solution, I put for each break of my ColorScheme, the colortype at 1 and I don't have anymore shades!! I got this problem since months and I always said that I will fix it later, and now, it's fixed!

Thanks again,

I hope I can help you next time!