This project is read-only.

9.3.5 demo software change projection

Sep 22, 2015 at 11:28 AM
Edited Sep 22, 2015 at 12:33 PM

I'm trying to set another projection in the 9.3.5 demo software (very nice by the way). I can set a new srid (EPSG:27582:) but each time I add an shp which is set to this projection, I get the message "Failed to reproject the layer:" I tried to look at the code and it seems to me that reprojection method is not set. Am I right ?


Edit ---
I tried to change InitGloablSettings
ReprojectLayersOnAdding = true ; no change (does not seem to be used),
and to se first shp to define system settings, no change, openstreetmap does not show up.

All this works with WGS84
Sep 23, 2015 at 4:46 AM
I had the same issue, I had to add the follow sub to get the reprojection to work. I am using VB in VS 2013.
Private Sub AxMap1_ProjectionMismatch(sender As Object, e As AxMapWinGIS._DMapEvents_ProjectionMismatchEvent) Handles AxMap1.ProjectionMismatch
    e.reproject = tkMwBoolean.blnTrue
    e.cancelAdding = tkMwBoolean.blnFalse
End Sub
Sep 28, 2015 at 1:19 PM

That's strange, because those lines are in the C# project, and do not apply any reprojection. I think that there should be here the reproject code and set _DMapEvents_LayerReprojectedEvent .success to true because it's checked in axmap1_LayerReprojected called after. But tha't just a guess. So far, I didn't understand well those events.