MapWingis 4.9.3 (ultimate) doesn´t show the map in Windows 7

Jan 12, 2015 at 12:51 PM
I have downloaded and installed the new version.
But now on Windows 7 doesn´t show the map.
Shows a black image before load a shapefile, and after loading too.
Jan 12, 2015 at 1:51 PM
what process did you follow?
what environment are you using?
did it work before.
are you in debug mode or complied?
thanks


Ross
Jan 12, 2015 at 2:33 PM
Edited Jan 14, 2015 at 10:54 AM
I am developing in Delphi XE3.
To 4.9.2 all right. But from today with the new version the map doesn´t show.
I compile for XP and for Windows 7.
I have anothers posts about it. This is the thread.
Now I am with Windows 7 at work (64 bits). Later at home with XP (32 bits) I continue the work.
The Map component (TMap implements _DMap interface) is a black ractangle even if color property is clWhite and doesn´t show anything because all is black!
Jan 15, 2015 at 4:45 PM
I've uninstalled MapWingis and reinstalled MapWinGIS-only-v4.9.3.3-Win32.exe
The map is doesn't appear, a black window appear. Help. I need resolve today!
Feb 10, 2015 at 2:28 PM
Edited Feb 10, 2015 at 2:46 PM
I just downloaded the last version (4.9.3.4)
The problem isn´t resolved. The map is black in Windows 7 and 8
In Windows XP it works !.

This is the map into my application running in Windows 7

and

This is the image after running dependency walker.

What to do?
Developer
Feb 10, 2015 at 5:02 PM
Edited Feb 10, 2015 at 5:03 PM
Hi NizamUlMulk, I can't see your screenshots (probably they should shared). It seems that nobody else reports this issue so perhaps it's related to Delphi. I don't have Delphi installed to test it. So I suggest you to compile a small test application with MapWinGIS control in it with your Delphi XE3 and upload it so I can test it and run a debugging session with it. Only please make sure that it's accessible, i.e. share it or use some public service (www.filedropper.com for example).